Los Foros de ASPTutor.com
Home | Perfil | Registrarse | Temas Activos | Miembros | Buscar | FAQ
Usuario:
Password:
 Todos los Foros
 ASP
 Subir a la carpeta de la bd
 Foro Bloqueado  Tema Bloqueado


Autor Temas
ignacioeml
Starting Member


21 Posts
Mensajes - 29 Jun 2003 :  13:57:05  Ver Perfil  Enviar Email
En el servidor me da el siguiente error:

Server.MapPath() error 'ASP 0175 : 80004005'

Disallowed Path Characters

/paginacine/intranet/centrales/tecnicointra.asp, line 6

The '..' characters are not allowed in the Path parameter for the MapPath method

Ya se que es por esto:
OCONN.OPEN "driver={Microsoft Access driver (*.mdb)};dbq=" & server.mappath("../db/cine.mdb")
¿como puedo subir al directorio de la base de datos sin ../?
Muchas gracias


dos
Moderator

España
1575 Posts
Posted - 29 Jun 2003 :  20:59:41  Ver perfil  Enviar e-mail
tienes instalado un servidor para asp.net verdad?? aunque no lo estes usando para asp.net, hay ciertas cosas como el que no se pueden usar los .. en funciones como server.mappath que estan hechas asi aproposito. Personalmente no se como deshabilitarlo, lo que si puedes hacer es meterle la ruta local en el servidor a pelo.

Para obtenerla pon algo asi

response.write server.mappath("/")

eso te dara la ruta local que seria algo como c:\inetpub\loquesea

cambia tu cadena de conexión por
OCONN.OPEN "driver={Microsoft Access driver (*.mdb)};dbq=loquetehayadadoelresponse.write/db/cine.mdb"

Tendrás que jugar un poquito para ajustarlo correctamente, y ya se que es un poco chapuzas esta solucion y que no es tan buena solucion como poner un simple mappath, pero si han capado el acceso a traves de los dos puntos (cosa lógica por otra parte porque con eso podrias acceder a cualquier parte del servidor y dadas las características de ".net" eso sería incompatible con su filosofia) habrá que apañarselas de otro modo.

Saludos.

Solo se ayuda al que se ayuda a si mismo. No esperes que nosotros resolvamos tus problemas si tu no te preocupas por intentar resolverlos tu antes.

Edited by - dos on 30 Jun 2003 00:44:44Inicio Pagina

ignacioeml
Starting Member


21 Posts
Posted - 01 Jul 2003 :  00:34:22  Ver perfil  Enviar e-mail
No no es un servidor .net pero la solucion que voy a coger es poner la base de datos en el nivel más bajo, asi todo solucionado.
Gracias

Inicio Pagina

mayela_ezequiel
Starting Member


6 Posts
Posted - 06 May 2007 :  01:18:54  Ver perfil  Enviar e-mail
quote:

En el servidor me da el siguiente error:

Server.MapPath() error 'ASP 0175 : 80004005'

Disallowed Path Characters

/paginacine/intranet/centrales/tecnicointra.asp, line 6

The '..' characters are not allowed in the Path parameter for the MapPath method

Ya se que es por esto:
OCONN.OPEN "driver={Microsoft Access driver (*.mdb)};dbq=" & server.mappath("../db/cine.mdb")
¿como puedo subir al directorio de la base de datos sin ../?
Muchas gracias




Este detalle lo solucione de la siguente forma...

de tenerlo asi

db.OPEN = ("Driver={MICROSOFT ACCESS DRIVER (*.mdb)}; DBQ=" & SERVER.MAPPATH("../data/enlace.mdb"))

lo temine de esta forma...

ruta_db = mid(Request.ServerVariables("URL"),1,instr(2,Request.ServerVariables("URL"),"/"))&"data/enlace.mdb"

db.OPEN = ("Driver={MICROSOFT ACCESS DRIVER (*.mdb)}; DBQ=" & SERVER.MAPPATH(ruta_db))

espero solucione el problema.

homo hominis, lupus estInicio Pagina

   
 Foro Bloqueado  Tema Bloqueado
Ir a:
Los Foros de ASPTutor.com Los Foros de ASPTutor.com
Ir al principio de la Página

 Imprimir Tema
 

Descargas de manuales¦ Ejemplos de código ¦ Artículos mas visitados ¦ Envía tu articulo ¦ Foros ¦
  Libro de visitas ¦Crea un enlace con ASPTutor 
 

    © 2001-Hasta hoy  Pedro Rufo Martín  contactar