Los Foros de ASPTutor.com
Home | Perfil | Registrarse | Temas Activos | Miembros | Buscar | FAQ
Usuario:
Password:
 Todos los Foros
 ADO
 registros
 Foro Bloqueado  Tema Bloqueado


Autor Temas
nestormontoya
Starting Member

Colombia
22 Posts
Mensajes - 01 Jan 2003 :  17:00:53  Ver Perfil  Enviar Email
Hola quisiera saber por que no puedo insertar un registro en una base de datos en internet, mientras que en mi equipo si funciona cunado utilizo un servidor local en Dreamweaver, las paginas que utilizo son las siguientes:

pagina4.asp

<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
<html>
<head>
<title>ingresar datos</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<body>
<p align="center"><strong>DIRECTORIO PERSONAL </strong></p>

<form method="post" action="pagina8.asp" >
<table bgcolor="#FFFFCC">
<tr>
<td><strong><font color="#0000CC">Cédula:</font></strong></td>
<td><input type="text" name="CEDULA"></td>
</tr>
<tr>
<td><strong><font color="#0000CC">Nombre:</font></strong></td>
<td><input type="text" name="NOMBRE"></td>
</tr>
<tr>
<td><strong><font color="#0000CC">Apellido:</font></strong></td>
<td><input type="text" name="APELLIDO"></td>
</tr>
<tr>
<td><strong><font color="#0000CC">Dirección:</font></strong></td>
<td><input type="text" name="DIRECCION"></td>
</tr>
<tr>
<td><strong><font color="#0000CC">Teléfono:</font></strong></td>
<td><input type="text" name="TELEFONO"></td>
</tr>
</table>
<input type="submit" value="Agregar" name="Enviar">
</form>

</body>
</html>

pagina8.asp

<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
<html>
<head>
<title>Documento sin t&iacute;tulo</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>
<script language="VBScript" runat="server">

Dim conexion,comando,SQL,Ced,Nom,Ape,Dire,Tele

set Conexion=Server.CreateObject("ADODB.Connection") 'Crear el objeto conexión
Conexion.Provider="Microsoft.Jet.OLEDB.4.0" 'Definir el tipo de proveedor. En este caso una BD ACCESS
Conexion.Open Server.MapPath("Directorio.mdb") 'Abrir la conexión

Ced=Request.Form("CEDULA")
Nom=Request.Form("NOMBRE")
Ape=Request.Form("APELLIDO")
Dire=Request.Form("DIRECCION")
Tele=Request.Form("TELEFONO")

SQL="INSERT INTO Amigos(Cédula,Nombre,Apellido,Dirección,Teléfono) values ('" & Ced & "','" & Nom & "','" & Ape & "','" & Dire & "','" & Tele & "')"

Set comando=CreateObject("ADODB.Command")
comando.CommandText=SQL
comando.ActiveConnection=conexion

comando.Execute

Response.Redirect("pagina9.asp")

</script>

</body>
</html>

pagina9.asp

<%@LANGUAGE="VBSCRIPT" CODEPAGE="1252"%>
<html>
<head>
<title>Documento sin t&iacute;tulo</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>
<script language="VBScript" runat="server">

Dim conexion
Dim registros
Dim basedatos
Dim SQL

Set conexion=CreateObject("ADODB.Connection")
conexion.Open "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" & Server.MapPath("Directorio.mdb")

SQL= "SELECT Cédula,Nombre,Apellido,Dirección,Teléfono FROM Amigos ORDER BY Nombre"

Set registros=CreateObject("ADODB.Recordset")
registros.ActiveConnection=conexion

registros.Open SQL

Response.Write "<table border=3 align=center bgcolor=#CCCCCC>"
Response.Write"<tr>"
Response.Write "<th>Cédula</th>"
Response.Write "<th>Nombre</th>"
Response.Write "<th>Apellido</th>"
Response.Write "<th>Dirección</th>"
Response.Write "<th>Teléfono</th>"
Response.Write "</tr>"

While Not registros.EOF

Response.Write"<tr>"
Response.Write "<td align=center>"&registros("Cédula")&"</td>"
Response.Write "<td align=center>"&registros("Nombre")&"</td>"
Response.Write "<td align=center>"&registros("Apellido")&"</td>"
Response.Write "<td align=center>"&registros("Dirección")&"</td>"
Response.Write "<td align=center>"&registros("Teléfono")&"</td>"
Response.Write "</tr>"

registros.MoveNext
Wend

Response.Write "</table>"

conexion.close
</script>
</body>
</html>

nubeazul
Moderator


814 Posts
Posted - 03 Jan 2003 :  10:22:06  Ver perfil  Enviar e-mail  Visit nubeazul's Homepage
¿pero que error te da?

Nubeazul
Contruyendo un Mundo más Azul y HumanoInicio Pagina

nestormontoya
Starting Member

Colombia
22 Posts
Posted - 04 Jan 2003 :  00:00:15  Ver perfil  Enviar e-mail
Gracias nubeazul por su interés en responderme, mira que el problema es que la página 4 si me abre e internet mientras que la nueve no. Creo que el error puede ser en que la base de datos deberia quedar en un directorio "db" del servidor. Ya probe las páginas en otro servidor: www.brinkster.com y hay si me funcionó.

Hasta pronto y bendiciones

Inicio Pagina

   
 Foro Bloqueado  Tema Bloqueado
Ir a:
Los Foros de ASPTutor.com Los Foros de ASPTutor.com
Ir al principio de la Página

 Imprimir Tema
 

Descargas de manuales¦ Ejemplos de código ¦ Artículos mas visitados ¦ Envía tu articulo ¦ Foros ¦
  Libro de visitas ¦Crea un enlace con ASPTutor 
 

    © 2001-Hasta hoy  Pedro Rufo Martín  contactar