Los Foros de ASPTutor.com
Home | Perfil | Registrarse | Temas Activos | Miembros | Buscar | FAQ
Usuario:
Password:
 Todos los Foros
 ASP
 Problema con cadena SQL
 Foro Bloqueado  Tema Bloqueado


Autor Temas
mtorrubia
Starting Member

España
8 Posts
Mensajes - 07 Apr 2005 :  10:18:35  Ver Perfil  Enviar Email
Tengo la siguiente variable que le pasa una consulta SQL a una base de datos:
strsql = "SELECT * FROM tblCE95 where UCase(titulo) like '%" & UCase(Request("titulo")) & "%'
AND UCase(Autor) like '%" & UCase(Request("Autor")) & "%'
order by "& orden & " "&alf

Como veis, hace una consulta a una tabla y devuelve registros según un formulario de consulta que le pasa los valores por medio de las variables.
El problema es que, con esta consulta, cuando un campo esta vacio, ya no me incluye ese registro en el resultado. Es decir(poniendo un ejemplo simplificado): Consulto libros cuyo Autor es "Perez" y hay un total de 10 registros con diversos datos, pero dos registros tienen el campo "Titulo" vacio. Entonces, ya no me muestra esos dos registros.
¿Alguien tiene idea de cómo se puede arreglar eso?
Gracias anticipadas

mtorrubia
Starting Member

España
8 Posts
Posted - 07 Apr 2005 :  10:34:55  Ver perfil  Enviar e-mail
Os pido disculpas a todos por precipitarme en consultar!
La solución era tan facil como incluir una clausula OR Campo = Null en cada variable.
La confusión me la produjo el hecho de que las consultas SQL de Acces no se comportan así

Inicio Pagina

   
 Foro Bloqueado  Tema Bloqueado
Ir a:
Los Foros de ASPTutor.com Los Foros de ASPTutor.com
Ir al principio de la Página

 Imprimir Tema
 

Descargas de manuales¦ Ejemplos de código ¦ Artículos mas visitados ¦ Envía tu articulo ¦ Foros ¦
  Libro de visitas ¦Crea un enlace con ASPTutor 
 

    © 2001-Hasta hoy  Pedro Rufo Martín  contactar